
What is EtherChannel in Cisco?
Etherchannel is a technology that allows you to bundle physical interfaces together and then create a single logical interface (Logical Link) in your switch. This technology is also known as the Link Aggregation protocol.
What are the benefits of configuring EtherChannel?
Etherchannel provides multiple benefits such as fault-tolerant and high speed in switches or routers in your backbone. Mean that if you bundle 4 interfaces, then one physical interface was down, but it still works with the other three interfaces. So, your connection still working.
Where we should configure EtherChannel?
Recommended you need to configure EtherChannel in your backbone infrastructure. With your Cisco switches and router in your backbone infra, you should consider the solutions that can prevent downtime operation. So, the link up between your switches or router is very important for you to configure the EtherChannel.
What is the Maximum interface for configuring EtherChannel?
You can configure EtherChannel with 16 physical interfaces but there are only 8 physical interfaces is Active. For the other 8 interfaces, you can set them to be standby interfaces. Also, you can configure EtherChannel with 2, 4, or 8 physical interfaces (FastEthernet, Gigabit, 10 Gigabit) in your backbone infrastructure.
What is the EtherChannel protocol in Cisco?
There is one protocol for configuring EtherChannel in Cisco, called Port Aggregation Protocol (PAgP) it is a proprietary EtherChannel protocol of Cisco that you can combine a maximum of 8 physical links into a single logical link. And Link Aggregation Control Protocol (LACP), is an IEEE 802.3ad standard (available with other vendor devices) you can combine up to 8 interfaces as active and another 8 interfaces can be set in standby mode.
What are the requirements of each physical interface for configuring EtherChannel?
Each interface should have the SAME mode/functions as bellow
- Switchport mode (Access or Trunk)
- Speed mode
- Allowed VLAN
- Duplex mode (Fast or Gigabit or 10 Gigabit)
How to Configure EtherChannel in Cisco Switch
In this article, we will configure EtherChannel in Cisco Switch. There are 3 core switches in the backbone infra and we want each connection of the core switch still connected even if there is one core switch down.
Scenario
- Bundle 4 physical interfaces of core switch 01&02 and 2 physical interfaces of switch 01&02 to switch 03 (See diagram drawing)
- Change the mode of each physical interface to the Trunk port
- Allow 2 VLANs in the EtherChannel (10 and 20)
You will get more detail and easy to apply the command line because now we will show you the diagram of how to configure Etherchannel in the Cisco switch below.

Please check the configuration below for the command line of each switch.
#Switch 01
1. Provide a basic configuration to switch 01
Switch>enable
Switch>configure terminal
Switch(config)#hostname CS01
CS01(config)#no ip domain-lookup
CS01(config)#ip domain-name abc.com
CS01(config)#line console 0
CS01(config-line)#logging synchronous
CS01(config-line)#exec-timeout 0 0
CS01(config-line)#exit
CS01(config)#line vty 0 4
CS01(config-line)#logging synchronous
CS01(config-line)#exec-timeout 0 0
CS01(config-line)#preivilege level 15
CS01(config-line)#password cisco123
CS01(config-line)#login
CS01(config-line)#exit
CS01(config)#line vty 5 15
CS01(config-line)#transport input none
CS01(config-line)#transport output none
CS01(config-line)#exit
CS01(config#banner motd #Configure EtherChannel#
Note: You can skip the basic configuration if you have configured it.
Read: How to Create VLAN in Cisco Switch
2. Shutdown the interface
CS01(config)#interface range gi1/0/1-4
CS01(config-if-range)#shutdown
CS01(config-if-range)#exit
CS01(config)#interface range gi1/0/5-6
CS01(config-if-range)#shutdown
CS01(config-if-range)#exit
3. Configure EtherChannel
CS01(config)#interface range gi1/0/1-4
CS01(config-if-range)#channel-group 12 mode active
CS01(config-if-range)#no shutdown
CS01(config-if-range)#exit
CS01(config)#interface range gi1/0/5-6
CS01(config-if-range)#channel-group 1 mode desirable
CS01(config-if-range)#no shutdown
CS01(config-if-range)#exit
CS01(config)#interface port-channel 12
CS01(config-if)#swtichport trunk encapsulation dot1q
CS01(config-if)#switchport mode trunk
CS01(config-if)#switchport trunk allowed vlan 10,20
CS01(config-if)#exit
CS01(config)#interface port-channel 1
CS01(config-if)#swtichport trunk encapsulation dot1q
CS01(config-if)#switchport mode trunk
CS01(config-if)#switchport trunk allowed vlan 10,20
CS01(config-if)#exit
#Switch 02
Provide a basic configuration the same as switch 01 and then configure the EtherChannel as the command line below
1. Shutdown interface
CS02(config)#interface range gi1/0/1-4
CS02(config-if-range)#shutdown
CS02(config-if-range)#exit
CS02(config)#interface range gi1/0/5-6
CS02(config-if-range)#shutdown
CS02(config-if-range)#exit
2. Configure EtherChannel
CS02(config)#interface range gi1/0/1-4
CS02(config-if-range)#channel-group 12 mode active
CS02(config-if-range)#no shutdown
CS02(config-if-range)#exit
CS02(config)#interface range gi1/0/7-8
CS02(config-if-range)#channel-group 2 mode desirable
CS02(config-if-range)#no shutdown
CS02(config-if-range)#exit
CS02(config)#interface port-channel 12
CS02(config-if)#swtichport trunk encapsulation dot1q
CS02(config-if)#switchport mode trunk
CS02(config-if)#switchport trunk allowed vlan 10,20
CS02(config-if)#exit
CS02(config)#interface port-channel 2
CS02(config-if)#swtichport trunk encapsulation dot1q
CS02(config-if)#switchport mode trunk
CS02(config-if)#switchport trunk allowed vlan 10,20
CS02(config-if)#exit
#Switch 03
Provide a basic configuration the same as switch 01 &02 and then configure the EtherChannel as the command line below
1. Shutdown interface
CS03(config)#interface range gi1/0/5-6
CS03(config-if-range)#shutdown
CS03(config-if-range)#exit
CS03(config)#interface range gi1/0/7-8
CS03(config-if-range)#shutdown
CS03(config-if-range)#exit
2. Configure EtherChannel
CS03(config)#interface range gi1/0/5-6
CS03(config-if-range)#channel-group 1 mode desirable
CS03(config-if-range)#no shutdown
CS03(config-if-range)#exit
CS03(config)#interface range gi1/0/7-8
CS03(config-if-range)#channel-group 2 mode auto
CS03(config-if-range)#no shutdown
CS03(config-if-range)#exit
CS03(config)#interface port-channel 1
CS03(config-if)#swtichport trunk encapsulation dot1q
CS03(config-if)#switchport mode trunk
CS03(config-if)#switchport trunk allowed vlan 10,20
CS03(config-if)#exit
CS03(config)#interface port-channel 2
CS03(config-if)#swtichport trunk encapsulation dot1q
CS03(config-if)#switchport mode trunk
CS03(config-if)#switchport trunk allowed vlan 10,20
CS03(config-if)#exit
Conclusion
Now, you have configured EtherChannel on switches. So, your link connection will be more stable and prevent downtime for your operation.
Can we configure EtherChannel in the different switch vendors?
Yes, you could. You can configure EtherChannel with different switches brand, but you need to make sure that the switch supports the EtherChannel protocol. We recommended you configure EtherChannel with the same switch model. Because it’s easy for you to troubleshoot and well-managed.